Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-1787

Document how to exclude transitive conflicting dependencies in Maven and Gradle

    Details

    • Type: Documentation
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8
    • Component/s: Documentation
    • Labels:
      None

      Description

      Add documentation regarding how to transitively exclude conflicting dependencies for each replacement module. This should cover:

      • When I use log4j-core, I should exclude log4j 1.x and logback
      • When I use log4j-1.2-api, I should exclude log4j 1.x and log4j-over-slf4j
      • When I use log4j-jcl, I should exclude jcl-over-slf4j, but I still need commons-logging
      • When I use log4j-jul, I should exclude jul-to-slf4j
      • When I use log4j-to-slf4j, I should exclude log4j-core

        Attachments

          Activity

            People

            • Assignee:
              jvz Matt Sicker
              Reporter:
              jvz Matt Sicker
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: