Log4j 2
  1. Log4j 2
  2. LOG4J2-101

Attribute "format" for SyslogAppender is mandatory

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta2
    • Fix Version/s: 2.0-beta3
    • Component/s: Appenders
    • Labels:
      None

      Description

      In the SyslogAppender the configuration attribute "Format" must be present, otherwise a NullPointerException is thrown in method "createAppender" when the following statement is executed:

      if (format.equalsIgnoreCase(RFC5424))

      The fix is simply to add a check so the "equalsIgnoreCase" is called only if the format variable isn't Null.

        Issue Links

          Activity

          Emanuele Colombo created issue -
          Ralph Goers added a comment -

          Verified the problem and fixed in revision 1400254. Please verify and close.

          Ralph Goers made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0-beta3 [ 12323368 ]
          Resolution Fixed [ 1 ]
          Emanuele Colombo added a comment -

          The problem is now solved. Thanks!

          Emanuele Colombo made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Ralph Goers made changes -
          Link This issue is duplicated by LOG4J2-121 [ LOG4J2-121 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          5h 23m 1 Ralph Goers 19/Oct/12 20:51
          Resolved Resolved Closed Closed
          2d 12h 9m 1 Emanuele Colombo 22/Oct/12 09:00

            People

            • Assignee:
              Unassigned
              Reporter:
              Emanuele Colombo
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development