Uploaded image for project: 'Apache Lens'
  1. Apache Lens
  2. LENS-1484

Lens Server pre commit build failing due to enunciate plugin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: server
    • Labels:
      None

      Description

      [ERROR] Failed to execute goal com.webcohesion.enunciate:enunciate-maven-plugin:2.5.0:docs (default) on project lens-server: freemarker.core._TemplateModelException: An error has occurred when reading existing sub-variable "securityRoles"; see cause exception! The type of the containing value was: extended_hash+string (com.webcohesion.enunciate.modules.jaxrs.api.impl.MethodImpl wrapped into f.e.b.StringModel)

        Attachments

        1. LENS-1484.01.patch
          1 kB
          Rajitha R
        2. LENS-1484.02.patch
          2 kB
          Rajitha R
        3. LENS-1484.03.patch
          1 kB
          Rajitha R
        4. LENS-1484.patch
          0.6 kB
          Puneet Gupta

          Activity

            People

            • Assignee:
              puneet884 Puneet Gupta
              Reporter:
              puneet884 Puneet Gupta
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: