Commons Lang
  1. Commons Lang
  2. LANG-81

[lang] Enum.equals does not handle different class loaders.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

      Description

      The Enum.equals method does not handle different class loaders even though the
      code comments say that it does. Working on a fix and unit test.

        Issue Links

          Activity

          ggregory@seagullsw.com added a comment -

          Fixed and added unit tests.

          Stephen Colebourne added a comment -
              • COM-2055 has been marked as a duplicate of this bug. ***
          Henri Yandell added a comment -

          2.1 released, closing.


            People

            • Assignee:
              Unassigned
              Reporter:
              Gary Gregory
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development