Uploaded image for project: 'Commons Lang'
  1. Commons Lang
  2. LANG-1608

Tests are not executed

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.11
    • Fix Version/s: 3.12.0
    • Component/s: General
    • Labels:
    • Flags:
      Important

      Description

      After an upgrading junit-jupiter from 5.6.2 to 5.7.0 the surefire plugin cannot execute tests.

       

      The reason is that org.junit-pioneer:junit-pioneer:0.9.2 transitively pulls incompatible version of org.junit.platform:junit-platform-commons:1.7.0. Here is a link to the issues.

      Also here are the notes on Dependencies.

       

       
       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ed_asatryan Edgar Asatryan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h