Uploaded image for project: 'Kylin'
  1. Kylin
  2. KYLIN-2892

Make Kylin compile with Java 9

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      When I attempted building with Java 9, I got:

      [ERROR] Failed to execute goal on project kylin-engine-mr: Could not resolve dependencies for project org.apache.kylin:kylin-engine-mr:jar:2.2.0-SNAPSHOT: Could not find artifact jdk.tools:jdk.tools:jar:1.7 at specified path /jdk-9/../lib/tools.jar -> [Help 1]
      

      The dependency seems to come from kylin-engine-mr module.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              yuzhihong@gmail.com Ted Yu
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: