Uploaded image for project: 'Kudu'
  1. Kudu
  2. KUDU-2951

kudu-python: clarify and document on supported Python versions

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: client, documentation, python
    • Labels:
      None

      Description

      Due to the widely circulating information on the planned obsolescence of Python2, there have been inquiries about versions of Python supported by kudu-python package.

      As it seems, running applications based on kudu-python using Python3 has been supported for a very long time. Anyway, it would be nice to clarify and confirm on the requirements w.r.t. using Python2/Python3 for building and running kudu-python.

      It's necessary to document the findings on the supported Python versions in the user-facing documentation such as documentation on Kudu Python client at the Kudu website.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              aserbin Alexey Serbin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: