Uploaded image for project: 'Kudu'
  1. Kudu
  2. KUDU-2092

Pull in krb5_is_config_principal() when running against older kerberos versions

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.4.0
    • Fix Version/s: n/a
    • Component/s: security
    • Labels:
      None

      Description

      On kerberos versions < krb5-1.8, the function krb5_is_config_principal() does not exist. Since our code uses that function, and we dynamically link against kerberos, we would be unable to build on systems that have these old kerberos versions.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sailesh Sailesh Mukil
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: