Uploaded image for project: 'Kudu'
  1. Kudu
  2. KUDU-1305

Blacklist using gcc 4.6 and 4.7

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7.0
    • Component/s: build
    • Labels:
      None

      Description

      We've discovered that KUDU-1030, thought to only manifest under gcc 4.6, also shows up with gcc 4.7. This was seen in the context of Debian 7, which uses gcc 4.7.2 throughout its lifespan (at least from 7.1 to 7.9), and as such, the default compiler is no good for building Kudu.

      We should prevent people from building Kudu with these broken compilers; a warning is probably not strong enough deterrence. Ideally we'd switch the compiler within cmake, but doing that is inadvisable. So we'll settle on a blacklist.

      On a related note, Todd suspects that maybe we're doing something "naughty" that is triggered by gcc 4.6 and 4.7. If we could find/fix that, obviously that's preferrable, but as of right now it's not clear what it would be.

        Attachments

          Activity

            People

            • Assignee:
              adar Adar Dembo
              Reporter:
              adar Adar Dembo
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: