Uploaded image for project: 'Apache Knox'
  1. Apache Knox
  2. KNOX-917

Knox Proxy - Pig view fails to load when using ambari thru KNOX

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • None
    • Server
    • None

    Description

      Problem seems to be caused by pig view java scripts making async postbacks to context that is not being handled by knox.
      Direct url without Knox:
      http://<host>:8080/#/main/views/PIG/1.0.0/PIG
      working script url:
      http://<host>:8080/api/v1/views/PIG/versions/1.0.0/instances/PIG/scripts?_=1482263718137
      Knox url
      https://<host>:8443/gateway/default/ambari/#/main/views/PIG/1.0.0/
      404 link url:
      https://<host>:8443/api/v1/views/default/versions/ambari/instances/views/scripts?_=1482263506651
      There are few more 404 links broken following same pattern as the above one.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            gnagar Gaurav Nagar
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment