Karaf
  1. Karaf
  2. KARAF-953

features.xml dropped into deploy BEFORE karaf is started are not recognised

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.4, 3.0.0
    • Fix Version/s: None
    • Component/s: karaf-feature
    • Labels:
      None

      Description

      a) If you copy a features.xml to the deploy folder AFTER karaf had been started it registeres the features.xml and starts all features;
      b) if you copy a features.xml to the deploy folder BEFORE karaf had been started the feature file is simply ignored.

      I'm convinced that behavior b) isn't planed but rather a bug...

      I've not tested the behavior by now on the master but I expect it to be the same there.

        Activity

        Andreas Pieber created issue -
        Ioannis Canellos made changes -
        Field Original Value New Value
        Assignee Ioannis Canellos [ iocanel ]
        Ioannis Canellos added a comment -

        Tried to reproduce it both using 2.2.5-SNAPSHOT and 3.0.0-SNAPSHTO and couldn't.

        Jamie goodyear added a comment -

        Bump to 2.2.6.

        Jamie goodyear made changes -
        Fix Version/s 2.2.6 [ 12319142 ]
        Fix Version/s 2.2.5 [ 12317857 ]
        Christian Schneider made changes -
        Fix Version/s 3.1.0 [ 12316946 ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Ioannis Canellos added a comment -

        This one is getting pretty old and I couldn't reproduce it and I think Andreas either (after reporting it).

        Ioannis Canellos made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Andreas Pieber added a comment -

        nope, it seams to work now; pretty strange... seams to be some other issue cross-referencing with this one...

        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Andreas Pieber added a comment -

        wrong target versions

        Andreas Pieber made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Andreas Pieber made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 3.1.0 [ 12316946 ]
        Fix Version/s 2.2.6 [ 12319142 ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        143d 5h 40m 1 Ioannis Canellos 12/Mar/12 16:17
        Resolved Resolved Closed Closed
        27d 18h 34m 1 Jamie goodyear 09/Apr/12 11:52
        Closed Closed Reopened Reopened
        33d 15h 43m 1 Andreas Pieber 13/May/12 03:35
        Reopened Reopened Closed Closed
        9s 1 Andreas Pieber 13/May/12 03:35

          People

          • Assignee:
            Ioannis Canellos
            Reporter:
            Andreas Pieber
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development