Karaf
  1. Karaf
  2. KARAF-952

config:propdel doesn't delete the property in the cfg file

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 3.0.0
    • Fix Version/s: 2.2.5, 3.0.0
    • Component/s: karaf-config
    • Labels:
      None

      Description

      When invoking:

      config:edit my.pid
      config:propdel key
      config:update

      the etc/my.pid.cfg still contain the key property.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4d 18h 46m 1 Jean-Baptiste Onofré 25/Oct/11 13:29
        Resolved Resolved Reopened Reopened
        17h 24m 1 Jean-Baptiste Onofré 26/Oct/11 06:53
        Reopened Reopened Resolved Resolved
        6h 23m 1 Jean-Baptiste Onofré 26/Oct/11 13:17
        Resolved Resolved Closed Closed
        92d 13h 34m 1 Jamie goodyear 27/Jan/12 01:52
        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jean-Baptiste Onofré made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jean-Baptiste Onofré added a comment -

        Fixed on trunk: revision 1189161.
        Fixed on karaf-2.2.x: revision 1189162.

        Jean-Baptiste Onofré made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Jean-Baptiste Onofré added a comment -

        The shell command has been fixed, but the ConfigMBean should be updated too.

        Jean-Baptiste Onofré made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jean-Baptiste Onofré added a comment -

        Fixed on karaf-2.2.x: revision 1188630.

        Jean-Baptiste Onofré added a comment -

        Fixed on trunk: revision 1188626.

        Jean-Baptiste Onofré added a comment -

        The issue is that the config:update command reload the properties from the cfg file, apply the change (new properties or property changes) and save back:

        Properties p = new Properties(storageFile);

        It means that if we remove a property in the session, it's not removed from the file.

        We should check the properties present in p but not present in the session properties, and remove it from p.

        Jean-Baptiste Onofré created issue -

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development