Karaf
  1. Karaf
  2. KARAF-934

Provide a way to select which features are to be installed when dropping a descriptor to the deploy folder.

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.5, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently when dropping a feature in the deploy folder it automatically starts all features (including transient).
      However, there are cases that the use doesn't want to install all of them. We need to provide a way to select which of the features are to be installed.

        Activity

        Ioannis Canellos created issue -
        David Jencks added a comment -

        Lets also consider lining up karaf feature support more with what's in the osgi subsystem spec. There, a subsystem (including a feature) is a jar with some manifest-like files indicating its contents (and isolation, etc etc). In particular there isn't an idea of a "feature repository" containing several features. I think you can represent a "feature repository" with an obr xml repository document, but I haven't tried.

        From this point of view, the problem is that we should be using features rather than feature repositories. Then its pretty clear what to do if you deploy a single feature.

        Ioannis Canellos added a comment -

        We will need to have a closer look at the subsystem spec.

        Ioannis Canellos added a comment -

        Committed on trunk.
        Also committed for branch 2.2.x (separately).

        Ioannis Canellos made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.2.5 [ 12317857 ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Resolution Fixed [ 1 ]
        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Ioannis Canellos
            Reporter:
            Ioannis Canellos
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development