Details

    • Type: Dependency upgrade Dependency upgrade
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None
    1. KARAF-855.patch
      6 kB
      Jean-Baptiste Onofré

      Issue Links

        Activity

        Jean-Baptiste Onofré added a comment -

        The patch allows to upgrade to OSGi r4.3 (including the corresponding Felix and Equinox frameworks).
        I have a issue when starting Karaf (around the system package) but I have to fix.

        Guillaume Nodet added a comment -

        The below patch seems to help a bit:

        diff --git a/assemblies/features/framework/src/main/filtered-resources/resources/etc/config.properties b/assemblies/features/framework/src/main/filtered-resources/resources/etc/config.properties
        index 4363c1d..5b3dbb5 100644
        --- a/assemblies/features/framework/src/main/filtered-resources/resources/etc/config.properties
        +++ b/assemblies/features/framework/src/main/filtered-resources/resources/etc/config.properties
        @@ -46,18 +46,24 @@ karaf.framework.felix=${karaf.default.repository}/org/apache/felix/org.apache.fe
         #
         # Framework config properties.
         #
        -org.osgi.framework.system.packages=org.osgi.framework; version=1.5.0, \
        - org.osgi.framework.launch; version=1.0.0, \
        - org.osgi.framework.hooks.service; version=1.0.0, \
        - org.osgi.service.packageadmin; version=1.2.0, \
        - org.osgi.service.startlevel; version=1.1.0, \
        - org.osgi.service.url; version=1.0.0, \
        - org.osgi.util.tracker; version=1.4.0, \
        - org.apache.karaf.jaas.boot; version=${karaf.osgi.version}, \
        - org.apache.karaf.version; version=${karaf.osgi.version}, \
        +org.osgi.framework.system.packages= \
        + org.osgi.framework.startlevel;uses:="org.osgi.framework";version="1.0", \
        + org.osgi.framework.wiring;uses:="org.osgi.framework";version="1.0", \
        + org.osgi.framework.hooks.bundle;uses:="org.osgi.framework";version="1.0", \
        + org.osgi.framework.hooks.service;uses:="org.osgi.framework";version="1.1", \
        + org.osgi.framework.hooks.resolver;uses:="org.osgi.framework.wiring";version="1.0", \
        + org.osgi.framework.launch;uses:="org.osgi.framework";version="1.0", \
        + org.osgi.framework;version="1.6",org.osgi.framework.hooks.weaving;uses:="org.osgi.framework.wiring";version="1.0", \
        + org.osgi.service.packageadmin;uses:="org.osgi.framework";version="1.2", \
        + org.osgi.service.url;version="1.0", \
        + org.osgi.service.startlevel;uses:="org.osgi.framework";version="1.1", \
        + org.osgi.util.tracker;uses:="org.osgi.framework";version="1.5", \
        + org.apache.karaf.jaas.boot;version="${karaf.osgi.version}", \
        + org.apache.karaf.version;version="${karaf.osgi.version}", \
          ${jre-${java.specification.version}}
         
        -org.osgi.framework.system.packages.extra=
        +# Extra packages appended after standard packages
        +#org.osgi.framework.system.packages.extra=
         
         # javax.transaction is needed to avoid class loader constraint violation when using javax.sql  
         org.osgi.framework.bootdelegation=org.apache.karaf.jaas.boot,sun.*,com.sun.*,javax.transaction,javax.transaction.*
        
        Jean-Baptiste Onofré added a comment -

        Thanks for the update Guillaume. I tried to update the config.properties but I didn't use the right version.

        I'm going to apply the patch to perform some tests.

        David Jencks added a comment -

        With these patches the build completes without error and both the felix and equinox full servers start for me. Is there any reason not to commit them now?

        Jamie goodyear added a comment -

        It all appears reasonable to me, are there additional test cases outside of out unit/integration testing that need attention?

        Jean-Baptiste Onofré added a comment -

        I'm going to apply the patches. I just saw a small issue but not able to reproduce anymore

        Jean-Baptiste Onofré added a comment -

        Revision 1197041.

        Jean-Baptiste Onofré added a comment -

        I gonna check if karaf-2.3 branch has been correctly updated to OSGi 4.3.0.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development