Details

    • Type: Dependency upgrade Dependency upgrade
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      In order to support OSGi R4.3 specification, we have to upgrade to Felix Framework 3.3.0 (that will certainly become 4.0.0).

      Waiting the Felix Framework release, I'm upgrading Karaf trunk to use Felix Framework 3.3.0-SNAPSHOT.

        Issue Links

          Activity

          Jean-Baptiste Onofré created issue -
          Jean-Baptiste Onofré made changes -
          Field Original Value New Value
          Link This issue blocks KARAF-855 [ KARAF-855 ]
          Jean-Baptiste Onofré made changes -
          Summary Upgrade to Felix Framework 3.3.0 Upgrade to Felix Framework 4.0
          Jean-Baptiste Onofré made changes -
          Summary Upgrade to Felix Framework 4.0 Upgrade to Felix Framework 4.0.1
          Jean-Baptiste Onofré made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Guillaume Nodet made changes -
          Fix Version/s 2.3.0 [ 12320554 ]
          Gavin made changes -
          Link This issue blocks KARAF-855 [ KARAF-855 ]
          Gavin made changes -
          Link This issue is depended upon by KARAF-855 [ KARAF-855 ]

            People

            • Assignee:
              Jean-Baptiste Onofré
              Reporter:
              Jean-Baptiste Onofré
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development