Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.4, 3.0.0, cellar-3.0.0, cellar-2.2.3
    • Component/s: None
    • Labels:
      None

      Description

      Some of Maven plugins used are quite "old". For instance, we still use Maven Surefire plugin 2.3.1 whereas the latest version is 2.9 (for instance, -DskipTests doesn't work with 2.3.1 version).

      I'm going to review and update all Maven plugins version.

        Activity

        Hide
        Jean-Baptiste Onofré added a comment -

        Fixed on trunk: revision 1165580.

        Show
        Jean-Baptiste Onofré added a comment - Fixed on trunk: revision 1165580.
        Hide
        Jean-Baptiste Onofré added a comment -

        Fixed on karaf-2.2.x: revision 1165584.

        Show
        Jean-Baptiste Onofré added a comment - Fixed on karaf-2.2.x: revision 1165584.
        Hide
        Jean-Baptiste Onofré added a comment -

        Fixed on cellar trunk: revision 1165613.
        Fixed on cellar-2.2.x: revision 1165616.

        Show
        Jean-Baptiste Onofré added a comment - Fixed on cellar trunk: revision 1165613. Fixed on cellar-2.2.x: revision 1165616.
        Hide
        Jean-Baptiste Onofré added a comment -

        I downgrade Felix maven-bundle-plugin to 2.3.4 to be JDK 1.5 compliant.

        Show
        Jean-Baptiste Onofré added a comment - I downgrade Felix maven-bundle-plugin to 2.3.4 to be JDK 1.5 compliant.

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development