Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      The Karaf Enterprise features descriptor is not correct:
      java.lang.IllegalArgumentException: Unable to validate mvn:org.apache.karaf.features.assembly/enterprise/2.1.99-SNAPSHOT/xml/features
      ...
      Caused by: org.xml.sax.SAXParseException: cvc-complex-type.3.2.2: Attribute 'description' is not allowed to appear in element 'feature'

      The problem is that the features schema is not correct:

      • description should be an attribute of the feature element
      • detail is an element of the feature element

      I will update the XSD in both features core and site/xmlns/features in this way.

        Activity

        Jean-Baptiste Onofré added a comment -

        For the feature core: revision 1060207.
        For the site: revision 1060208.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development