Karaf
  1. Karaf
  2. KARAF-288

Shell history doesn't work anymore (at leas on windows)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: karaf-shell
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      With the latest version from svn, the shell history (key-up) doesn't work anymore, at least on windows right now.

        Issue Links

          Activity

          Guillaume Nodet added a comment -

          This has to be related to the new jline library we now use.
          I'll try to investigate.

          Jean-Baptiste Onofré added a comment -

          FYI, I've just made a try on Linux and Solaris. It's working fine.

          So it seems that the issue is Windows related.

          Achim Nierbeck added a comment -

          yeah on my linux machine it also works
          so this is an issue only on windows. I guess I keep this os around for a while for testing then

          Guillaume Nodet added a comment -

          Another related problem on windows is that the escape key does not work correctly when entering the reverse history lookup using ^R (the escape key should exit that mode).

          Guillaume Nodet added a comment -

          Committing to https://svn.apache.org/repos/asf/karaf/trunk ...
          M shell/console/src/main/java/org/apache/karaf/shell/console/jline/TerminalFactory.java
          Committed r1040079


            People

            • Assignee:
              Guillaume Nodet
              Reporter:
              Achim Nierbeck
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development