Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-278

ActiveMQ 5.4.1 feature has a missing dependency

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      karaf@root> features:install activemq
      Error executing command: Could not start bundle mvn:org.apache.activemq/activemq-console/5.4.1 in feature(s) : Unresolved constraint in bundle org.apache.activemq.activemq-console [88]: Unable to resolve 88.0: missing requirement [88.0] package; (package=org.jasypt.encryption.pbe) - [88.0] package; (package=org.jasypt.encryption.pbe)

      Easily remedied by first installing a wrapped version of the dependency:

      karaf@root> install wrap:mvn:org.jasypt/jasypt/1.6

      Apologies if this issue is filed against the wrong project.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              earcam Caspar MacRae
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: