Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2303

Command completer stopped working after RC1

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.0
    • Fix Version/s: None
    • Component/s: karaf-shell
    • Labels:
      None
    • Environment:

      Windows 7, JDK 7

      Description

      At some point after Karaf 3.0.0RC1, pressing the tab key at the terminal has stopped showing a list of commands or completing a command. It just tabs the cursor in the console. Something I noticed that is related, is that if I hit ctrl-c while I'm tailing a log in the Karaf Console, it normally would return me to the Karaf prompt. It now terminates Karaf all together now. Ctrl-D doesn't terminate Karaf either. I guess as I'm writing this and thinking of more things to test, something seems to just plain be broken in the Karaf shell all together.

      Just to reiterate, running RC1 works perfectly fine. When I'm testing on the latest snapshot, I'm just unzipping and running, to make sure it's clear I'm not making any modifications first.

        Activity

        jbonofre Jean-Baptiste Onofré added a comment -

        It works fine for me on Linux:

        1/ completion is OK
        2/ get out of log:tail using CTRL-C
        3/ CTRL-D to stop Karaf

        I gonna test on Windows VM.

        rmoquin Ryan Moquin added a comment -

        It works via ssh though if i locally ssh into it from the same machine. And
        has worked on every other machine I've tried it on. Basically, either you
        might as well attribute it to some weird bug in jdk that is exposed when
        using any code produced after RC1, or leave it open but I need to figure
        out a starting point to debug it. I did a folder compare on the rc1 code
        and I couldn't find any source code differences that looked remotely
        related, so I'm baffled. It's like the keys for the shell commands just
        aren't taking effect. So it's up to you, I simply cannot figure out where
        to start investigating.

        Ryan
        On May 20, 2013 8:19 AM, "Jean-Baptiste Onofré (JIRA)" <jira@apache.org>

        rmoquin Ryan Moquin added a comment -

        I can only think it's my jdk which is 1.7.0_17-b02. Hotspot client is
        build 23.7-b01 (if that second part even matters). If I can ssh locally to
        it amd ot works fine I can only think it's the jdk. Since every single
        other machine I try it on works.. it seems very localized to my
        environment. Just weird rc1 is fine.

        Ryan
        On May 20, 2013 8:19 AM, "Jean-Baptiste Onofré (JIRA)" <jira@apache.org>

        jbonofre Jean-Baptiste Onofré added a comment -

        I tried with:

        java version "1.7.0_21"
        Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
        Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

        without problem.

        Ryan, I close this Jira as "cannot reproduce", feel free to reopen it.


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            rmoquin Ryan Moquin
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development