Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2125

"Components" tab not shown in WebConsole

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.10, 2.3.0, 2.3.1
    • Fix Version/s: 2.3.2, 2.4.0, 3.0.0
    • Component/s: karaf-webconsole
    • Labels:
      None

      Description

      Switching from 2.2.9 to 2.2.10 the webconsole does not show the "Components" tab any longer.

      Tested with org.apache.felix.scr bundle version 1.6.0-SNAPSHOT and 1.6.2 (latest)

      There are no Sub-Tasks for this issue.

        Activity

        mitaes Michael Taeschner added a comment -

        I assume it has to do with

        and caused by WebConsole upgrade.

        tnarake Timo Naroska added a comment -

        In webconsole 4.0.0 the components tab moved to a plugin bundle of its own org.apache.felix:org.apache.felix.webconsole.plugins.ds:1.0.0.

        Unfortunately the bundle does not work in karaf, because of an issue in the karaf-webconsole (opened sub-issue) and because it requires package "org.json" which is currently not exported by any bundle in karaf.

        mitaes Michael Taeschner added a comment -

        Components tab also not available in versions 3.2.0, 3.2.1 using either felix scr bundle (see description) or Karaf scr feature.

        tnarake Timo Naroska added a comment -

        Attached a fix for 3.0.0. It relies on subtasks KARAF-2228 and KARAF-2229. 3.0.0 allows conditionals in feature.xml, I added the webconsole.ds plugin to the scr feature using a conditional on webconsole.
        AFAIK 2.x.x branches don't support conditionals, so not sure where to add the plugin there. Maybe a new feature "webconsole-scr"?

        jbonofre Jean-Baptiste Onofré added a comment -

        As features condition doesn't exist on Karaf 2.x serie, I introduced a webconsole-scr feature to install the scr feature and the Felix WebConsole DS plugin.

        jbonofre Jean-Baptiste Onofré added a comment -

        Added webconsole-scr feature on karaf-2.3.x: http://svn.apache.org/viewvc?view=revision&revision=1488864

        jbonofre Jean-Baptiste Onofré added a comment -

        Added webconsole-scr feature on karaf-2.x: http://svn.apache.org/viewvc?view=revision&revision=1488875

        mitaes Michael Taeschner added a comment -

        tested successfully


          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            mitaes Michael Taeschner
          • Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development