Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2052

Progress bar doesn't display properly on 80 char consoles

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.3.1, 3.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu 10.04, default width gnome-terminal

      Description

      If you set karaf.delay.console=true you get a progress bar when loading Karaf. Problem is that you need > 100 column width on your console for it to display properly. When you have 80 char width the progress bar prints a newline each time:

      [janstey@duffman apache-karaf-2.3.0]$ ./bin/karaf
      Apache Karaf starting up. Press Enter to open shell now ...
      1% [=>
      1% [=>
      1% [=>
      1% [=>
      3% [===>
      3% [===>
      3% [===>
      5% [=====>
      5% [=====>
      5% [=====>
      7% [=======>
      7% [=======>

      Will attach a patch for this shortly.

      1. progress_bar_win-trunk.patch
        1 kB
        Jonathan Anstey
      2. progress_bar_win-karaf-2.3.x.patch
        1 kB
        Jonathan Anstey
      3. KARAF-2052-trunk.patch
        1 kB
        Jonathan Anstey
      4. KARAF-2052.patch
        1 kB
        Jonathan Anstey

        Activity

        janstey Jonathan Anstey added a comment -

        Patch to fix issue on karaf-2.3.x branch.

        ffang Freeman Fang added a comment -

        If I change my display resolution to 800* 600 I can reproduce this issue

        janstey Jonathan Anstey added a comment -

        Patch for trunk.

        ffang Freeman Fang added a comment -

        apply patch on behalf of Jonathan Anstey with thanks
        http://svn.apache.org/viewvc?rev=1419963&view=rev for trunk
        http://svn.apache.org/viewvc?rev=1418180&view=rev for 2.3.x branch

        janstey Jonathan Anstey added a comment -

        Unfortunately this is also a problem on Windows and on Windows you need one less char due to extra newline chars. Further patches are attached to fix this.

        janstey Jonathan Anstey added a comment -

        Attached more patches to fix this on Windows too.

        ffang Freeman Fang added a comment -

        patch applied to fix this issue on windows
        http://svn.apache.org/viewvc?rev=1420656&view=rev for trunk
        http://svn.apache.org/viewvc?rev=1420659&view=rev for 2.3.x branch


          People

          • Assignee:
            ffang Freeman Fang
            Reporter:
            janstey Jonathan Anstey
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development