Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-2010

Cannot install application-without-isolation feature : Could not start bundle mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 in feature(s) obr-2.3.0: Activator start error in bundle org.apache.felix.bundlerepository [3086].

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.3.0
    • Fix Version/s: None
    • Component/s: karaf
    • Labels:
      None
    • Environment:

      Description

      karaf@root> features:install -v application-without-isolation 
      Installing feature application-without-isolation 1.0.0
      Installing feature obr 2.3.0
      Installing bundle mvn:org.apache.felix/org.osgi.service.obr/1.0.2
      Installing bundle mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6
      Installing bundle mvn:org.apache.karaf.shell/org.apache.karaf.shell.obr/2.3.0
      Installing bundle mvn:org.apache.karaf.features/org.apache.karaf.features.obr/2.3.0
      Installing bundle mvn:org.apache.karaf.management.mbeans/org.apache.karaf.management.mbeans.obr/2.3.0
      Installing bundle mvn:org.ops4j.pax.url/pax-url-obr/1.3.5
      Found installed bundle: org.apache.aries.blueprint.api [11]
      Found installed bundle: org.apache.aries.blueprint.core [7]
      Found installed bundle: org.apache.aries.blueprint.cm [13]
      Found installed bundle: org.apache.aries.proxy.api [9]
      Found installed bundle: org.apache.aries.proxy.impl [12]
      Found installed bundle: org.apache.aries.util [8]
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.resolver.obr/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.install/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.api/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.management/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.utils/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.modeller/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.default.local.platform/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.resolver.noop/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.deployment.management/1.0.0
      Installing bundle mvn:org.apache.aries.application/org.apache.aries.application.runtime/1.0.0
      Error executing command: Could not start bundle mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 in feature(s) obr-2.3.0: Activator start error in bundle org.apache.felix.bundlerepository [3086].
      

      Log:

      2012-11-11 14:40:21,491 | INFO  | l Console Thread | Console                          | araf.shell.console.jline.Console  199 | 14 - org.apache.karaf.shell.console - 2.3.0 | Exception caught while executing command
      java.lang.Exception: Could not start bundle mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 in feature(s) obr-2.3.0: Activator start error in bundle org.apache.felix.bundlerepository [3086].
              at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:476)[20:org.apache.karaf.features.core:2.3.0]
              at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:393)[20:org.apache.karaf.features.core:2.3.0]
              at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:389)[20:org.apache.karaf.features.core:2.3.0]
              at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)[22:org.apache.karaf.features.command:2.3.0]
              at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:41)[22:org.apache.karaf.features.command:2.3.0]
              at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)[14:org.apache.karaf.shell.console:2.3.0]
              at org.apache.karaf.shell.console.jline.Console.run(Console.java:175)[14:org.apache.karaf.shell.console:2.3.0]
              at java.lang.Thread.run(Thread.java:722)[:1.7.0_07]
      Caused by: org.osgi.framework.BundleException: Activator start error in bundle org.apache.felix.bundlerepository [3086].
              at org.apache.felix.framework.Felix.activateBundle(Felix.java:2027)[org.apache.felix.framework-4.0.3.jar:]
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1895)[org.apache.felix.framework-4.0.3.jar:]
              at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.3.jar:]
              at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.3.jar:]
              at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:473)[20:org.apache.karaf.features.core:2.3.0]
              ... 15 more
      Caused by: java.lang.IllegalArgumentException
              at org.apache.felix.bundlerepository.impl.RequirementImpl.setFilter(RequirementImpl.java:78)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.DataModelHelperImpl.createImportFilter(DataModelHelperImpl.java:775)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.DataModelHelperImpl.doImports(DataModelHelperImpl.java:738)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.DataModelHelperImpl.populate(DataModelHelperImpl.java:556)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.LocalResourceImpl.initialize(LocalResourceImpl.java:56)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.LocalResourceImpl.<init>(LocalResourceImpl.java:39)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.LocalRepositoryImpl.addBundle(LocalRepositoryImpl.java:98)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.LocalRepositoryImpl.initialize(LocalRepositoryImpl.java:163)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.LocalRepositoryImpl.<init>(LocalRepositoryImpl.java:45)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.RepositoryAdminImpl.<init>(RepositoryAdminImpl.java:69)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.Activator.start(Activator.java:70)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:645)[org.apache.felix.framework-4.0.3.jar:]
              at org.apache.felix.framework.Felix.activateBundle(Felix.java:1977)[org.apache.felix.framework-4.0.3.jar:]
              ... 19 more
      Caused by: org.osgi.framework.InvalidSyntaxException: Missing attr: =split)(mandatory:<*)): (&(package=org.neo4j.unsafe.batchinsert)(=split)(mandatory:<*))
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_attr(FilterImpl.java:1390)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_item(FilterImpl.java:1291)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_filtercomp(FilterImpl.java:1233)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_filter(FilterImpl.java:1198)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_and(FilterImpl.java:1248)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_filtercomp(FilterImpl.java:1222)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse_filter(FilterImpl.java:1198)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl$Parser.parse(FilterImpl.java:1172)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.utils.filter.FilterImpl.newInstance(FilterImpl.java:87)[3086:org.apache.felix.bundlerepository:1.6.6]
              at org.apache.felix.bundlerepository.impl.RequirementImpl.setFilter(RequirementImpl.java:74)[3086:org.apache.felix.bundlerepository:1.6.6]
              ... 31 more
      

      BTW... where "application-WITH-isolation" feature ?

        Attachments

          Activity

            People

            • Assignee:
              jbonofre Jean-Baptiste Onofré
              Reporter:
              ceefour Hendy Irawan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: