Details

    • Type: Dependency upgrade
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: karaf-webcontainer
    • Labels:
      None

      Description

      In order to get all bug fixes, and especially the great work by Achim about Tomcat support, we are going to update to Pax-Web 3.0 in Karaf 3.0.0.

      A first update to SNAPSHOT (for testing purpose) would be interesting.

        Activity

        jbonofre Jean-Baptiste Onofré added a comment -

        I updated to Pax Web 3.0.0-SNAPSHOT.

        topping Brian Topping added a comment -

        This upgrade has broken ResourceServlet in the whiteboard extender. It appears there are unit tests for the ResourceServlet, but no integration tests for resources, and probably other aspects of the Karaf integration.

        Tomcat support is probably valuable to some new folks, but this change makes the server unusable for existing ones, and I think we should move back to 2.1.0 until such time that Pax Web has better testing for existing use cases.

        achim_nierbeck Achim Nierbeck added a comment - - edited

        Hi Brian, that's the exact reason to switch to 3.0.0-SNAPSHOT now to find such flaws.
        I'll be real great full if you could open a issue for this at pax-web (with maybe a itest or description of how to reproduce)

        To make this easier there is a iTest at Pax-Web for it WhiteboardResourceFilterIntegrationTest I would really be thankful if you could give me a hint what is missing there ...

        topping Brian Topping added a comment -

        Hi Achim,

        Yes, I figured that was the case, and it's totally reasonable but there are also people using 3.0.0-SNAPSHOT for development. The problem isn't that developers can't stay with an older version, but when the dependency soup changes enough that there's a required move to the latest version (like what happened recently with the update to features schema 1.2.0), changes like this update to pax-web can cause the whole system to be completely unusable.

        It's a balance, you know? For a while there, the release of 3.0.0 was imminent, now it seems a ways out. Nobody would go into production with it for reasons like this, when the expectations of a release cycle change and they aren't fully communicated, others can get pulled back.

        In my opinion, this is the kind of change that should go into a later release, that is all.

        I didn't file on this because I prefer to fix it myself, but I have some stuff to do this weekend already.

        Thanks for the input!

        Brian

        achim_nierbeck Achim Nierbeck added a comment -

        Hi Brian,

        well I know that it's always a balance, but to be honest such changes, as going for a 3.0.0 Pax-Web with CDI support (forget about Tomcat right now)
        and such is best taken by a 3.0 a major change then any other version.

        People are already requesting 2.1.x (Pax-Web) for the 2.3.x karaf line.
        So I really don't want people to miss this part for the 3.0 of Karaf since the alternative would be to wait for a 4 or 3.x maybe and that one wasn't really thought of yet. So even since it failed for you, it's better to fail now then later on, when everything is "released".
        And TBH since I know what stuff was changed I'm not sure a 2.1.1 of Pax-Web wouldn't be affected either.
        So if you could give me a detailed description on what fails I can work a iTest out of it and fix it.

        jbonofre Jean-Baptiste Onofré added a comment -

          People

          • Assignee:
            jbonofre Jean-Baptiste Onofré
            Reporter:
            jbonofre Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development