Karaf
  1. Karaf
  2. KARAF-1900

create project for private compendium build for java 7

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      since BJ will rather die then change his mind
      https://www.osgi.org/bugzilla/show_bug.cgi?id=153

      karaf must create project for private compendium build for java 7
      see KARAF-1898 KARAF-1899

        Activity

        Andrei Pozolotin created issue -
        Andrei Pozolotin made changes -
        Field Original Value New Value
        Environment since BJ will rather die then change his mind
        https://www.osgi.org/bugzilla/show_bug.cgi?id=153

        karaf must create project for private compendium build for java 7
        see KARAF-1898 KARAF-1899
        Andrei Pozolotin made changes -
        Description since BJ will rather die then change his mind
        https://www.osgi.org/bugzilla/show_bug.cgi?id=153

        karaf must create project for private compendium build for java 7
        see KARAF-1898 KARAF-1899
        Christian Schneider made changes -
        Assignee Christian Schneider [ chris@die-schneider.net ]
        Christian Schneider added a comment -

        I just committed the code to build the compendium.

        Christian Schneider made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Andrei Pozolotin added a comment -

        since osgi does not want to release these jars,
        do you think it would be appropriate to
        keep karaf-osgi-core and karaf-osgi-compendium
        outside of karaf main trunk and instead
        release them independently of karaf
        for benefits of others, such as felix community [ and me ]

        Christian Schneider added a comment -

        I also think we should provide this and had proposed it when we started to create the osgi core jar.
        The question is of course if Karaf would be the right place for this. So we also asked in felix and servicemix but no one wanted to do it. You can popose this on the dev list of course. Perhaps people changed their minds in the mean time.

        Andrei Pozolotin added a comment -

        cool. I cross-posted request to karaf-dev and felix-dev.

        Jean-Baptiste Onofré made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Assignee Christian Schneider [ chris@die-schneider.net ] Jean-Baptiste Onofré [ jbonofre ]
        Jean-Baptiste Onofré made changes -
        Fix Version/s 2.3.0 [ 12320554 ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré made changes -
        Fix Version/s 2.3.0 [ 12320554 ]
        Andreas Pieber added a comment -

        If I've interpreted the responses on the Felix list correctly it seams that David Bosschaert is going to give this a shot. So we might want to keep that issue stalled for the moment.

        Christian Schneider added a comment -

        The issue is already fixed for trunk since a while but we should not do it for 2.3.x for the moment. As soon as David publishes the artifacts we should also remove our own artifacts again.

        Jean-Baptiste Onofré made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        10h 13m 1 Christian Schneider 05/Oct/12 10:58
        Resolved Resolved Reopened Reopened
        3d 2h 36m 1 Jean-Baptiste Onofré 08/Oct/12 13:35
        Reopened Reopened Resolved Resolved
        8d 1h 15m 1 Jean-Baptiste Onofré 16/Oct/12 14:50

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Andrei Pozolotin
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development