Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      When starting the minimal distribution, all commands fail to load:

      ERROR: Bundle org.apache.karaf.shell.packages [29] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)() not found.(version>=1.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)() not found.(version>=1.0.0)))]

        Activity

        Jean-Baptiste Onofré created issue -
        Jean-Baptiste Onofré added a comment -

        The shell console now have a dependency to sshd (in order to use the ssh agent). The problem is that mina/sshd is not define in the startup.properties of the minimal distribution.

        Jean-Baptiste Onofré made changes -
        Field Original Value New Value
        Assignee Jean-Baptiste Onofré [ jbonofre ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré added a comment -

        Marking sshd.agent as optional should be done on trunk as well.

        Jean-Baptiste Onofré made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        6d 17h 56m 1 Jean-Baptiste Onofré 25/Sep/12 08:05

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development