Uploaded image for project: 'Karaf'
  1. Karaf
  2. KARAF-1845

Minimal distribution doesn't start

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      When starting the minimal distribution, all commands fail to load:

      ERROR: Bundle org.apache.karaf.shell.packages [29] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)() not found.(version>=1.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages [29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(Unable to render embedded object: File ( Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)() not found.(version>=1.0.0)))]

        Attachments

          Activity

            People

            • Assignee:
              jbonofre Jean-Baptiste Onofré
              Reporter:
              jbonofre Jean-Baptiste Onofré
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: