Details

      Description

      I started up a vanilla Karaf 2.2.8, and executed
      karaf@root> command-watch info

        Activity

        Claus Ibsen created issue -
        Jean-Baptiste Onofré made changes -
        Field Original Value New Value
        Assignee Jean-Baptiste Onofré [ jbonofre ]
        Jean-Baptiste Onofré added a comment -

        Thanks for the report Claus. I reproduce and fix.

        Jean-Baptiste Onofré made changes -
        Fix Version/s 2.2.9 [ 12321741 ]
        Jean-Baptiste Onofré added a comment -

        The problem is an infinite loop on info. As info is a "special" commannd, watching info will result to a kind of infinite loop.

        I will add a check to prevent this.

        Jean-Baptiste Onofré added a comment -

        In fact, the issue is not a loop, it's not the good command which is executed.

        If you do command-watch shell:info, it works fine, but the info takes the bundle:info alias instead of shell:info.

        Jean-Baptiste Onofré made changes -
        Fix Version/s 2.3.0 [ 12320554 ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré made changes -
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré added a comment -

        It works fine on trunk.

        Jean-Baptiste Onofré made changes -
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré added a comment -

        After a fresh test, it doesn't work on trunk neither. The scope is not the correct one.

        Jean-Baptiste Onofré made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        42d 15h 59m 1 Jean-Baptiste Onofré 15/Aug/12 04:25
        Resolved Resolved Closed Closed
        124d 7h 19m 1 Jamie goodyear 17/Dec/12 10:44

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development