Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: eik-core
    • Labels:
      None

      Description

      if you launch eclipse:eclipse on eik source, The manifest is a mistake.
      For import project i have copy old .project file and renamed

      Please see the attach

      1. pom.patch
        0.4 kB
        filippo balicchia
      2. Manifest.patch
        3 kB
        filippo balicchia
      3. org.apache.commons.collections.tar.gz
        2 kB
        filippo balicchia

        Activity

        filippo balicchia created issue -
        filippo balicchia made changes -
        Field Original Value New Value
        Attachment mina.core.patch [ 12533287 ]
        Attachment org.apache.aries.jmx.core.patch [ 12533288 ]
        Attachment org.apache.karaf.eik.core.patch [ 12533289 ]
        Attachment org.apache.karaf.eik.feature.patch [ 12533290 ]
        Attachment org.apache.karaf.eik.felix.patch [ 12533291 ]
        Attachment org.apache.karaf.eik.hooks.patch [ 12533292 ]
        Attachment org.apache.karaf.eik.jmx.feature.patch [ 12533293 ]
        Attachment org.apache.karaf.eik.jmx.patch [ 12533294 ]
        Attachment org.apache.karaf.eik.p2.feature.patch [ 12533295 ]
        Attachment org.apache.karaf.eik.ui.patch [ 12533296 ]
        Attachment org.apache.karaf.eik.update.patch [ 12533297 ]
        Attachment org.apache.karaf.eik.workbench.patch [ 12533298 ]
        Attachment org.apache.karaf.eik.wtp.core.patch [ 12533299 ]
        Attachment org.apache.karaf.eik.wtp.feature.patch [ 12533300 ]
        Attachment org.apache.karaf.eik.wtp.ui.patch [ 12533301 ]
        Attachment org.apache.sshd.core.patch [ 12533302 ]
        Attachment org.fusesource.jansi.patch [ 12533303 ]
        Attachment org.ops4j.pax.url.mvn.patch [ 12533304 ]
        Łukasz Dywicki added a comment -

        Hey Filippo,
        You can get proper set up of .project and .classpath with maven-eclipse-plugin configuration. Things like eclipse project nature can be configured in pom.xml

        filippo balicchia added a comment -

        Hey Łukasz,
        I've tried to configure maven-eclipse-plugin v2.9 but with
        the documentation http://maven.apache.org/plugins/maven-eclipse-plugin/eclipse-mojo.html
        I was not been able to get to eik prefork.
        It seems that the two files have been modified by hand.
        if configure eclipse plugins with pde enable you'll see that there are in classpath all libs
        that in eclipse workspace are not necessary and with documentation i was not enable to say on eclipse
        plugin not to include these libraries

        filippo balicchia made changes -
        Component/s eik-core [ 12319409 ]
        Component/s karaf-os-integration [ 12313731 ]
        Jean-Baptiste Onofré made changes -
        Assignee Jean-Baptiste Onofré [ jbonofre ]
        filippo balicchia added a comment -

        To import eik in eclipse we can use M2E.
        If in our environment we have installed the plugin many of the previous patches released are not required.
        It depends on what you want to do ... M2E and IMHO this is the best choice.

        Please see the attach of bundle org.apache.commons.collections. With this eik compile in eclipse with out error.
        For close the jira need to resolve this problem http://wiki.eclipse.org/M2E_plugin_execution_not_covered that i Hope to resolve asap.

        filippo balicchia made changes -
        Attachment org.apache.commons.collections.tar.gz [ 12544040 ]
        Attachment pom.xml [ 12544041 ]
        filippo balicchia added a comment -

        From my point of view jira can be closed
        If your eclipse has install the following plugins

        m2e
        typco
        wst
        jst

        import project with "Existing Maven Projects" and ignore alert
        as indicated in paragraph Common problems of
        http://wiki.eclipse.org/M2E_plugin_execution_not_covered

        the project compile also in eclipse
        If interesting please apply patch

        filippo balicchia made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Andreas Pieber added a comment -

        Hey Filippo,

        Would it be possible to create a single patch of all your changes and also including the documentation update? I would really like to apply the changes but the amount of patches makes it quite risky for me doing some errors during the apply.

        Thank you very much and kind regards,
        Andreas

        filippo balicchia made changes -
        Attachment org.apache.aries.jmx.core.patch [ 12533288 ]
        filippo balicchia made changes -
        Attachment mina.core.patch [ 12533287 ]
        filippo balicchia made changes -
        Attachment org.ops4j.pax.url.mvn.patch [ 12533304 ]
        filippo balicchia made changes -
        Attachment org.apache.sshd.core.patch [ 12533302 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.workbench.patch [ 12533298 ]
        filippo balicchia made changes -
        Attachment org.fusesource.jansi.patch [ 12533303 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.wtp.ui.patch [ 12533301 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.wtp.feature.patch [ 12533300 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.wtp.core.patch [ 12533299 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.update.patch [ 12533297 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.ui.patch [ 12533296 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.p2.feature.patch [ 12533295 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.jmx.patch [ 12533294 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.jmx.feature.patch [ 12533293 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.hooks.patch [ 12533292 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.felix.patch [ 12533291 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.feature.patch [ 12533290 ]
        filippo balicchia made changes -
        Attachment org.apache.karaf.eik.core.patch [ 12533289 ]
        filippo balicchia added a comment -

        cleaning

        filippo balicchia made changes -
        Attachment Manifest.patch [ 12544766 ]
        filippo balicchia made changes -
        Attachment pom.xml [ 12544041 ]
        filippo balicchia made changes -
        Attachment pom.patch [ 12544767 ]
        filippo balicchia added a comment -

        Hey Andreas,
        I have made cleaning about the patch that i sent.

        The patch does not include documentation. For that i have open other jira task.
        KARAF-1800

        Thanks

        --Filippo

        Andreas Pieber made changes -
        Assignee Jean-Baptiste Onofré [ jbonofre ] Andreas Pieber [ pieber ]
        Andreas Pieber made changes -
        Assignee Andreas Pieber [ pieber ] Jean-Baptiste Onofré [ jbonofre ]
        Stephen Evanchik added a comment -

        Looking at the latest patches I'm not sure what the problem is.

        filippo balicchia added a comment -

        The goal of the patch is to import in eclipse eik project without errors
        With the patch and the use of m2e. you can import the project in eclipse with view Problems empty

        Jean-Baptiste Onofré added a comment -

        Yeah, we made a similar update on Karaf itself to support m2e (especially around the Karaf commands).


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            filippo balicchia
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development