Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.6
    • Fix Version/s: 2.2.7, 2.3.0, 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Configuration update doesn't store changes to the persistent storage.

      See attached example.

      To run example build it with:
      mvn install
      Then put generated bundle "config-update-1.0.jar" to the deploy folder.

      Expected: property "size" value was changed from "500" to "1000" in etc/org.apache.karaf.log.cfg

      Actual: changes are not stored to file, but we can see them in Karaf with "config:list".

      1. test.zip
        3 kB
        Alexander Osadchiy

        Issue Links

          Activity

          Jean-Baptiste Onofré added a comment -

          You are right, I reproduced it using a simple: log:set DEBUG => the etc/org.ops4j.pax.logging.cfg file is not updated.

          Christian Schneider added a comment -

          How is this supposed to work? As far as I know the persistent storage is only changed when updating the config using the karaf shell or the karaf config mbean.

          Christian Schneider added a comment -

          I just tested the provided example on Karaf 2.2.5 and it indeed updates the config file. I have no idea though how this works. When I did the refactoring I did not know that this was expected to work so I did not even check this.

          Christian Schneider added a comment -

          I was able to fix the problem by downgrading felix fileinstall to 3.1.10 in Karaf 2.2.7-SNAPSHOT. So it seems the problem is in fileinstall or the combination of felix fileinstall and felix config admin. On the other hand it shows that felix already handles the writing of config files. So I will try to remove the Karaf code that also does this.

          Christian Schneider added a comment -

          Downgraded felix fileinstall for branches and trunk. On trunk I also removed the complete persistence code in Karaf as it is not needed anymore

          Andreas Pieber added a comment -

          would be great if you could also add a itest to the suite validating this behavior and making sure we don't break it again in the future.

          Jean-Baptiste Onofré added a comment -

          Downgrading FileInstall is not a good solution as it breaks the support of path containing special characters (like "(x86)" for instance).

          I'm going to propose a patch to Felix FileInstall and deal with Guillaume to have a new FileInstall release.

          Jean-Baptiste Onofré added a comment -

          I submitted the patch to Felix FileInstall. I tested it, it works fine.


            People

            • Assignee:
              Jean-Baptiste Onofré
              Reporter:
              Alexander Osadchiy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development