Karaf
  1. Karaf
  2. KARAF-1269

aries-annotation feature doesn't install

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: karaf-feature
    • Labels:
      None

      Description

      karaf@root> feature:install aries-annotation
      Error executing command: Could not start bundle mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.annotation.impl/0.3.2 in feature(s) aries-annotation-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.aries.blueprint.annotation.impl [74]: Unable to resolve 74.0: missing requirement [74.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util)(version>=0.4.0)(!(version>=0.5.0)))

      Aries annotation update required

        Issue Links

          Activity

          Hide
          Christian Schneider added a comment -

          Aries annotations works now

          Show
          Christian Schneider added a comment - Aries annotations works now
          Hide
          Christian Schneider added a comment -

          I just tried to install aries util 0.4 in addition to 0.5 and the annotations bundle works. Would that be a solution?

          Show
          Christian Schneider added a comment - I just tried to install aries util 0.4 in addition to 0.5 and the annotations bundle works. Would that be a solution?

            People

            • Assignee:
              Christian Schneider
              Reporter:
              Jean-Baptiste Onofré
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development