Karaf
  1. Karaf
  2. KARAF-1139

Redeploy kar cause installing old feature

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 2.2.5
    • Fix Version/s: 2.2.6, 3.0.0
    • Component/s: karaf-kar
    • Labels:
      None

      Description

      1. Put first KAR to deploy folder:
      karaf@root> list
      START LEVEL 100 , List Threshold: 50
      ID State Blueprint Level Name
      [ 50] [Active ] [ ] [ 60] Apache Commons IO Bundle (1.4)
      2. Uninstall feature:
      karaf@root> features:uninstall newService-feature
      3. Put second KAR to deploy folder:
      karaf@root> list
      START LEVEL 100 , List Threshold: 50
      ID State Blueprint Level Name
      [ 50] [Active ] [ ] [ 60] Apache Commons IO Bundle (1.4)
      Expected: commons-lang bundle also installed.

      1. karaf.log
        12 kB
        Alexey Markevich
      2. 2.kar
        357 kB
        Alexey Markevich
      3. 1.kar
        97 kB
        Alexey Markevich

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        In Progress In Progress Open Open
        7d 18h 49m 1 Jean-Baptiste Onofré 23/Mar/12 12:51
        Open Open In Progress In Progress
        70d 9h 20m 2 Jean-Baptiste Onofré 23/Mar/12 12:51
        In Progress In Progress Resolved Resolved
        3d 19h 48m 1 Jean-Baptiste Onofré 27/Mar/12 09:40
        Resolved Resolved Closed Closed
        13d 53m 1 Jamie goodyear 09/Apr/12 10:33
        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jean-Baptiste Onofré made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jean-Baptiste Onofré made changes -
        Fix Version/s 3.0.0 [ 12316040 ]
        Jean-Baptiste Onofré added a comment -

        So the KAR deployer should:

        • refresh the URL of the feature repository
        • install (in order to update) the features
        Jean-Baptiste Onofré added a comment -

        The local-repo is updated with the new feature XML.

        The problem is that the Kar deployer should call a feature repository refresh.

        Jean-Baptiste Onofré made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Jean-Baptiste Onofré made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Jean-Baptiste Onofré made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Jean-Baptiste Onofré made changes -
        Fix Version/s 2.2.6 [ 12319142 ]
        Jean-Baptiste Onofré made changes -
        Assignee Jean-Baptiste Onofré [ jbonofre ]
        Alexey Markevich made changes -
        Attachment karaf.log [ 12509518 ]
        Alexey Markevich made changes -
        Attachment 2.kar [ 12509517 ]
        Alexey Markevich made changes -
        Field Original Value New Value
        Attachment 1.kar [ 12509516 ]
        Alexey Markevich created issue -

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Alexey Markevich
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development