Karaf
  1. Karaf
  2. KARAF-1121

Error when installing feature camel-cxf : jetty.xml is empty

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 2.2.5
    • Fix Version/s: 2.2.6
    • Component/s: None
    • Labels:
      None

      Description

      Found a problem when installing camel-cxf.

      Steps to reproduce:
      add staging repo (https://repository.apache.org/content/repositories/orgapachekaraf-382/) to org.ops4j.pax.url.mvn.cfg

      > features:addurl mvn:org.apache.camel.karaf/apache-camel/2.8.3/xml/features
      > features:install camel-cxf

      2011-12-22 10:54:31.797:INFO:oejs.Server:jetty-7.5.4.v20111024
      2011-12-22 10:54:31.897:INFO:oejs.AbstractConnector:Started NIOSocketConnectorWrapper@0.0.0.0:8080 STARTING
      2011-12-22 10:54:32.050:WARN:oejx.XmlParser:FATAL@file:/C:/java/apache-karaf-2.2.5/etc/jetty.xml line:1 col:1 : org.xml.sax.SAXParseException: Premature end of
      file.

      First of course these log outputs appear on the console which is issue https://issues.apache.org/jira/browse/KARAF-1117.

      The error above is because jetty.xml is empty. I think we should correct this.

        Issue Links

          Activity

          Christian Schneider added a comment -

          Issues 1122 better describes the problem

          Christian Schneider added a comment -

          I found that the issue happens when you do not add the staging repo first.

          When it is not present then features:install camel-cxf shows the error below and creates the empty jetty.xml:
          Error executing command: URL [mvn:org.apache.karaf/apache-karaf/2.2.5/xml/jettyconfig] could not be resolved.

          So this may be an eror in features:install but I think it does not block 2.2.5

          Jean-Baptiste Onofré added a comment -

          I don't reproduce it on my from scratch installation.


            People

            • Assignee:
              Jean-Baptiste Onofré
              Reporter:
              Christian Schneider
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development