Karaf
  1. Karaf
  2. KARAF-1022

java.io.tmpdir system property should use $KARAF_DATA/tmp in place of $KARAF_BASE/tmp

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 3.0.0
    • Fix Version/s: 2.2.5, 3.0.0
    • Component/s: karaf-core
    • Labels:
      None

      Description

      To avoid multiple "working directories", the java.io.tmpdir should be in the data folder (as others temp and working directories).

      It allows users the use karaf clean command to complete clean all working directories.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4h 33m 1 Jean-Baptiste Onofré 18/Nov/11 13:27
        Resolved Resolved Closed Closed
        69d 12h 31m 1 Jamie goodyear 27/Jan/12 01:58
        Jamie goodyear made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jean-Baptiste Onofré made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Jean-Baptiste Onofré added a comment -

        Fixed on karaf-2.2.x: revision 1203642.

        Show
        Jean-Baptiste Onofré added a comment - Fixed on karaf-2.2.x: revision 1203642.
        Hide
        Jean-Baptiste Onofré added a comment -

        Fixed on trunk: revision 1203631.

        Show
        Jean-Baptiste Onofré added a comment - Fixed on trunk: revision 1203631.
        Jean-Baptiste Onofré made changes -
        Summary java.io.tmpdir sysem property should use $KARAF_BASE/data/tmp in place of $KARAF_BASE/tmp java.io.tmpdir system property should use $KARAF_DATA/tmp in place of $KARAF_BASE/tmp
        Hide
        Jean-Baptiste Onofré added a comment -

        Yes, it's what I had in mind. Thanks for clarifying my mind

        Show
        Jean-Baptiste Onofré added a comment - Yes, it's what I had in mind. Thanks for clarifying my mind
        Hide
        Andreas Pieber added a comment -

        well, better to use KARAF_DATA instead of KARAF_BASE/data

        Show
        Andreas Pieber added a comment - well, better to use KARAF_DATA instead of KARAF_BASE/data
        Jean-Baptiste Onofré made changes -
        Field Original Value New Value
        Assignee Jean-Baptiste Onofré [ jbonofre ]
        Fix Version/s 2.2.5 [ 12317857 ]
        Fix Version/s 3.0.0 [ 12316040 ]
        Affects Version/s 2.2.5 [ 12317857 ]
        Affects Version/s 3.0.0 [ 12316040 ]
        Component/s karaf-core [ 12313724 ]
        Jean-Baptiste Onofré created issue -

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development