Kafka
  1. Kafka
  2. KAFKA-92

upgrade to latest stable 0.7.x sbt

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Component/s: None
    • Labels:
      None

      Description

      None of the changes look particularly important, but there isn't a reason to stay with an older version.

      http://code.google.com/p/simple-build-tool/wiki/Changes

      Old google group thread: http://groups.google.com/group/kafka-dev/browse_thread/thread/1c7b06a8c550fe23/08f3b2f9cd2059b0?lnk=gst&q=sbt#08f3b2f9cd2059b0

      1. k92-v1.txt
        0.9 kB
        Chris Burroughs

        Issue Links

          Activity

          Hide
          Chris Burroughs added a comment -
          Show
          Chris Burroughs added a comment - Diff doesn't include the binary: http://code.google.com/p/simple-build-tool/downloads/list
          Hide
          Chris Burroughs added a comment -

          So I think this is a totally safe backwards compatible upgrade, but has anyone else had a chance to give it a test?

          Show
          Chris Burroughs added a comment - So I think this is a totally safe backwards compatible upgrade, but has anyone else had a chance to give it a test?
          Hide
          Jun Rao added a comment -

          Tried it and was able to build package, test and idea. +1

          Show
          Jun Rao added a comment - Tried it and was able to build package, test and idea. +1
          Hide
          Jun Rao added a comment -

          Chris, do you want to get this committed for 0.7 release? If so, we need this to be done by today.

          Show
          Jun Rao added a comment - Chris, do you want to get this committed for 0.7 release? If so, we need this to be done by today.
          Hide
          Joel Koshy added a comment -

          It turns out that this is the trigger for KAFKA-147, as it causes junit-3.8.1 to get pulled in.

          Can we revert to 0.7.5? We are anyway going to upgrade to 0.10.1 in KAFKA-134.

          Show
          Joel Koshy added a comment - It turns out that this is the trigger for KAFKA-147 , as it causes junit-3.8.1 to get pulled in. Can we revert to 0.7.5? We are anyway going to upgrade to 0.10.1 in KAFKA-134 .
          Hide
          Neha Narkhede added a comment -

          This bug fix is causing another blocker bug - https://issues.apache.org/jira/browse/KAFKA-147

          It seems like we will need to stick to 0.7.5 for now, and later upgrade to the latest SBT, which apparently fixes the issue that KAFKA-147 runs into.

          We will have to revert this checkin - 1178669

          Show
          Neha Narkhede added a comment - This bug fix is causing another blocker bug - https://issues.apache.org/jira/browse/KAFKA-147 It seems like we will need to stick to 0.7.5 for now, and later upgrade to the latest SBT, which apparently fixes the issue that KAFKA-147 runs into. We will have to revert this checkin - 1178669
          Hide
          Chris Burroughs added a comment -

          FWIW I can't reproduce KAFKA-134, but if you have confirmed that reverting fixes it I'm cool with going back to 0.7.5. (Sorry for the crazy bug hunt!)

          Show
          Chris Burroughs added a comment - FWIW I can't reproduce KAFKA-134 , but if you have confirmed that reverting fixes it I'm cool with going back to 0.7.5. (Sorry for the crazy bug hunt!)
          Hide
          Chris Burroughs added a comment -

          Ah, I see Neha already did.

          Show
          Chris Burroughs added a comment - Ah, I see Neha already did.

            People

            • Assignee:
              Chris Burroughs
              Reporter:
              Chris Burroughs
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development