Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None

      Description

      A time index that:

      • Has minimal performance impact (such as by being append only)
      • Is suitable for
      • Works with getOffsetsBefore
      • Can have it's granularity configured. With numbers >= 1 minute being "normal".
      • Can be disabled

      See mailing list discussion : http://mail-archives.apache.org/mod_mbox/incubator-kafka-dev/201107.mbox/%3C4E2F678E.6060500@gmail.com%3E

        Activity

        ijuma Ismael Juma added a comment -

        Duplicate of KAFKA-3163

        cburroughs Chris Burroughs added a comment -

        Note to self: This came up on the user list and there was also significant interest in also indexing by message number ("I would like to go back 10,000 messages, please give me that offset").

        jkreps Jay Kreps added a comment -

        As a related thing, to make this really useful we should integrate it into the consumer API. I.e. give an API along the lines of consumer.resetTo(long).


          People

          • Assignee:
            cburroughs Chris Burroughs
            Reporter:
            cburroughs Chris Burroughs
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development