Kafka
  1. Kafka
  2. KAFKA-719

Kafka broker shuts down due to irrecoverable IO error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: None
    • Component/s: log
    • Labels:

      Description

      2013/01/22 03:48:18.144 ERROR [KafkaApis] [request-expiration-task] [kafka] [] [KafkaApi-277] error when processing request (service_metrics,2,1155,2000000)
      java.nio.channels.ClosedChannelException
      at sun.nio.ch.FileChannelImpl.ensureOpen(FileChannelImpl.java:88)
      at sun.nio.ch.FileChannelImpl.read(FileChannelImpl.java:613)
      at kafka.log.FileMessageSet.searchFor(FileMessageSet.scala:83)
      at kafka.log.LogSegment.translateOffset(LogSegment.scala:76)
      at kafka.log.LogSegment.read(LogSegment.scala:90)
      at kafka.log.Log.read(Log.scala:390)
      at kafka.server.KafkaApis.kafka$server$KafkaApis$$readMessageSet(KafkaApis.scala:372)
      at kafka.server.KafkaApis$$anonfun$kafka$server$KafkaApis$$readMessageSets$1.apply(KafkaApis.scala:330)
      at kafka.server.KafkaApis$$anonfun$kafka$server$KafkaApis$$readMessageSets$1.apply(KafkaApis.scala:326)
      at scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:206)
      at scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:206)
      at scala.collection.immutable.Map$Map2.foreach(Map.scala:127)
      at scala.collection.TraversableLike$class.map(TraversableLike.scala:206)
      at scala.collection.immutable.Map$Map2.map(Map.scala:110)
      at kafka.server.KafkaApis.kafka$server$KafkaApis$$readMessageSets(KafkaApis.scala:326)
      at kafka.server.KafkaApis$FetchRequestPurgatory.expire(KafkaApis.scala:528)
      at kafka.server.KafkaApis$FetchRequestPurgatory.expire(KafkaApis.scala:510)
      at kafka.server.RequestPurgatory$ExpiredRequestReaper.run(RequestPurgatory.scala:222)
      at java.lang.Thread.run(Thread.java:619)
      2013/01/22 03:48:18.989 INFO [Processor] [kafka-processor-10251-2] [kafka] [] Closing socket connection to /172.18.146.132.
      2013/01/22 03:48:18.989 INFO [Processor] [kafka-processor-10251-1] [kafka] [] Closing socket connection to /172.18.146.132.
      2013/01/22 03:48:18.998 FATAL [KafkaApis] [kafka-request-handler-4] [kafka] [] [KafkaApi-277] Halting due to unrecoverable I/O error while handling produce request:
      kafka.common.KafkaStorageException: I/O exception in append to log 'service_metrics-2'
      at kafka.log.Log.append(Log.scala:301)
      at kafka.server.KafkaApis$$anonfun$appendToLocalLog$2.apply(KafkaApis.scala:249)
      at kafka.server.KafkaApis$$anonfun$appendToLocalLog$2.apply(KafkaApis.scala:242)
      at scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:206)
      at scala.collection.TraversableLike$$anonfun$map$1.apply(TraversableLike.scala:206)
      at scala.collection.immutable.Map$Map1.foreach(Map.scala:105)
      at scala.collection.TraversableLike$class.map(TraversableLike.scala:206)
      at scala.collection.immutable.Map$Map1.map(Map.scala:93)
      at kafka.server.KafkaApis.appendToLocalLog(KafkaApis.scala:242)
      at kafka.server.KafkaApis.handleProducerRequest(KafkaApis.scala:181)
      at kafka.server.KafkaApis.handle(KafkaApis.scala:58)
      at kafka.server.KafkaRequestHandler.run(KafkaRequestHandler.scala:41)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.nio.channels.ClosedChannelException
      at sun.nio.ch.FileChannelImpl.ensureOpen(FileChannelImpl.java:88)
      at sun.nio.ch.FileChannelImpl.write(FileChannelImpl.java:189)
      at kafka.message.ByteBufferMessageSet.writeTo(ByteBufferMessageSet.scala:128)
      at kafka.log.FileMessageSet.append(FileMessageSet.scala:146)
      at kafka.log.LogSegment.append(LogSegment.scala:64)
      at kafka.log.Log.append(Log.scala:286)

        Issue Links

          Activity

          Neha Narkhede created issue -
          Jay Kreps added a comment -

          Isn't this the same as KAFKA-695?

          Neha Narkhede made changes -
          Field Original Value New Value
          Labels bugs bugs p1
          Neha Narkhede made changes -
          Link This issue duplicates KAFKA-695 [ KAFKA-695 ]
          Neha Narkhede made changes -
          Assignee Jay Kreps [ jkreps ] Jun Rao [ junrao ]
          Neha Narkhede made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Neha Narkhede made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Jun Rao
              Reporter:
              Neha Narkhede
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development