Kafka
  1. Kafka
  2. KAFKA-529

kafka.server.ReplicaFetcherThread: java.lang.IndexOutOfBoundsException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      1. Attached file system_test_1348521165.tar.gz contains all the associated log files for this test session.

      2. The system test output log can be found at: system_test_1348521165/system_test_output.log

      3. The following log message can be found at: system_test_1348521165/logs/broker-2/kafka_server_9092.log

      [2012-09-24 14:14:19,601] WARN No previously checkpointed highwatermark value found for topic test_1 partition 1. Returning 0 as the highwatermark (ka
      fka.server.HighwaterMarkCheckpoint)
      [2012-09-24 14:14:19,604] INFO [Kafka Log on Broker 2], Truncated log segment /tmp/kafka_server_2_logs/test_1-1/00000000000000000000.kafka to target o
      ffset 0 (kafka.log.Log)
      [2012-09-24 14:14:19,611] INFO [ReplicaFetcherThread-1-0-on-broker-2-], Starting (kafka.server.ReplicaFetcherThread)
      [2012-09-24 14:14:19,611] INFO [ReplicaFetcherManager on broker 2, ], adding fetcher on topic test_1, partion 1, initOffset 0 to broker 1 with fetcherId 0 (kafka.server.ReplicaFetcherManager)
      [2012-09-24 14:14:19,973] ERROR [ReplicaFetcherThread-1-0-on-broker-2-], Error due to (kafka.server.ReplicaFetcherThread)
      java.lang.IndexOutOfBoundsException
      at java.nio.Buffer.checkIndex(Buffer.java:512)
      at java.nio.HeapByteBuffer.get(HeapByteBuffer.java:121)
      at kafka.message.Message.magic(Message.scala:119)
      at kafka.message.Message.checksum(Message.scala:132)
      at kafka.message.Message.isValid(Message.scala:144)
      at kafka.message.ByteBufferMessageSet$$anon$1.makeNextOuter(ByteBufferMessageSet.scala:118)
      at kafka.message.ByteBufferMessageSet$$anon$1.makeNext(ByteBufferMessageSet.scala:149)
      at kafka.message.ByteBufferMessageSet$$anon$1.makeNext(ByteBufferMessageSet.scala:89)
      at kafka.utils.IteratorTemplate.maybeComputeNext(IteratorTemplate.scala:61)
      at kafka.utils.IteratorTemplate.hasNext(IteratorTemplate.scala:53)
      at kafka.message.ByteBufferMessageSet.verifyMessageSize(ByteBufferMessageSet.scala:79)
      at kafka.log.Log.append(Log.scala:250)
      at kafka.server.ReplicaFetcherThread.processPartitionData(ReplicaFetcherThread.scala:42)
      at kafka.server.AbstractFetcherThread$$anonfun$doWork$5.apply(AbstractFetcherThread.scala:103)
      at kafka.server.AbstractFetcherThread$$anonfun$doWork$5.apply(AbstractFetcherThread.scala:96)
      at scala.collection.immutable.Map$Map1.foreach(Map.scala:105)
      at kafka.server.AbstractFetcherThread.doWork(AbstractFetcherThread.scala:96)
      at kafka.utils.ShutdownableThread.run(ShutdownableThread.scala:50)
      [2012-09-24 14:14:19,975] INFO [ReplicaFetcherThread-1-0-on-broker-2-], Stopped (kafka.server.ReplicaFetcherThread)

        Activity

        John Fung added a comment -

        This cannot be reproduced any more with the fix from KAFKA-528. So mark this FIXED.


          People

          • Assignee:
            Unassigned
            Reporter:
            John Fung
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development