We got some user feedback, that is it sometimes not clear from the JavaDocs, if provides Serdes are for input or output records.
The phrase "for this stream" means the input stream. But it is rather subtle. We should revisit the complete JavaDocs and rephrase the Serde parameter description if required. We should also rename the parameter names (in the example about, maybe from keySerde to inputKStreamKeySerde)