Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-4892

kafka 0.8.2.1 getOffsetsBefore API returning correct offset given timestamp in unix epoch format

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 0.8.2.1
    • Fix Version/s: None
    • Component/s: clients, offset manager
    • Labels:
      None
    • Environment:
      ubuntu 16.04

      Description

      I am seeing unexpected behavior in the getOffsetsBefore method of the client API.

      I understand the granularity of 'start-from-offset' via kafka spout is based on how many log segments you have.

      I have created a demo program that repro's this on my
      git hub account [ https://github.com/buildlackey/kafkaOffsetBug/blob/master/README.md ],
      and I have also posted this same question to stack overflow with
      a detailed set of steps for how to repro this issue
      (using my test program and scripts).

      See: http://stackoverflow.com/questions/42775128/kafka-0-8-2-1-getoffsetsbefore-api-returning-correct-offset-given-timestamp-in-u

      Thanks in advance for your help !

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              chris@mz.com Chris Bedford
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: