Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-3618

Handle ApiVersionRequest before SASL handshake

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0.1
    • Fix Version/s: 0.10.0.0
    • Component/s: security
    • Labels:
      None

      Description

      Handle ApiVersionRequest in SaslServer authenticator before SaslHandshakeRequest to enable clients to obtain handshake request version from the server. This should be implemented after KAFKA-3307 which adds support for version requests after authentication and KAFKA-3149 which adds handshake requests.

        Attachments

          Activity

            People

            • Assignee:
              rsivaram Rajini Sivaram
              Reporter:
              rsivaram Rajini Sivaram
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: