Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-2590 KIP-28: Kafka Streams Checklist
  3. KAFKA-3449

Rename filterOut() to filterNot() to achieve better terminology

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently the Streams DSL has a function called filterOut(), which is the negation of filter(). Instead of using our own name "filterOut", we should rather use the more familiar name "filterNot" (cf. Scala's filter/filterNot functions).

        Attachments

          Activity

            People

            • Assignee:
              acosentino Andrea Cosentino
              Reporter:
              miguno Michael Noll
              Reviewer:
              Yasuhiro Matsuda
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: