Background: We stopped using the terminology of a "job" in the context of Kafka Streams. For example, the upcoming Streams docs do not refer to a "job" anymore; otherwise it's very confusing to readers that are familiar with "jobs" in Hadoop, Spark, Storm, etc. because there's no equivalent concept of a "job" in Streams.
We should update the Streams code (see "cd streams/ ; git grep job" for a starting point) to reflect this accordingly. Notably, the configuration option "job.id" should be changed to "application.id".