Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0.0
    • Component/s: None
    • Labels:
      None

      Description

      From some collected feedbacks, here is a list of potential improvements that we want to make:

      1. Remove AggregateSupplier for aggregate, and provide more built-in aggregations. [DONE]

      2. Join to return KeyValue<>.

      3. "Windows" class syntax-sugers. [DONE]

      4. Add print() to KTable / KStream.

      5. flatMap / flatMapValues to return arrays in addition to Iterable.

      6. make the API function names aligned with Java 8+, e.g. filterOut -> filterNot

      7. collapse process() and transform() in KStream.

      8. validate Streaming configs and allow passing properties to KafkaStreaming. [DONE]

      9. Rename KafkaStreaming to Streams. [DONE]

      Also move some of the state package into internals, and create a new top-level common folder with KeyValue / etc in it.

        Attachments

          Activity

            People

            • Assignee:
              guozhang Guozhang Wang
              Reporter:
              guozhang Guozhang Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: