Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.7
    • Fix Version/s: None
    • Component/s: core
    • Labels:

      Description

      the zkclient jar bundled with kafka should be synced with what is available on maven central. the artifact which has group com.github.sgroschupf, artifact id zkclient and version 0.1 is from a day after the one bundled with kafka and should thus be sufficient for kafka's needs.

      I have tested it locally and find no regressions.

        Activity

        Pierre-Yves Ritschard added a comment -

        Solve kafka-245

        Pierre-Yves Ritschard added a comment -

        With the following patch changing the version of the zkclient artifact, it is now possible to fetch it directly from maven central. This kills the zkclient specific code in KafkaProject.config

        Neha Narkhede added a comment -

        Thanks for the patch ! One thing missing in there is deleting the zkclient jar in core/lib, since now it will be pulled from Maven. However, I made that change and will check in this patch.

        Neha Narkhede added a comment -

        Committed this

        Jun Rao added a comment -

        Do we know the github revision/date corresponding to the zkclient 0.1 release?

        Neha Narkhede added a comment -

        From Maven, the date is 04-13-2011. ( http://repo1.maven.org/maven2/com/github/sgroschupf/zkclient/maven-metadata.xml )

        The one we had was zkclient-20110412.jar which was a day older. Am I right ?

        Pierre-Yves Ritschard added a comment -

        the jar contains files from april 13th, there's a "0.1.0" git tag but the last commit is from 2010


          People

          • Assignee:
            Pierre-Yves Ritschard
            Reporter:
            Pierre-Yves Ritschard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development