Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-2315

Kafka binary distribution may contain incorrect dependencies

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.2.1
    • Fix Version/s: 0.9.0.1
    • Component/s: packaging
    • Labels:
      None

      Description

      It seems, that the 0.8.2.1 binary was released with wrong dependencies
      According to this pom file (https://repo1.maven.org/maven2/org/apache/kafka/kafka-clients/0.8.2.1/kafka-clients-0.8.2.1.pom) the version of slf4j-log4j12 should be 1.7.6 instead of 1.6.1, which caused me some anomalies in the debug messages.

        Attachments

          Activity

            People

            • Assignee:
              omkreddy Manikumar
              Reporter:
              mzs MÓZES Ádám István
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: