Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1717

remove netty dependency through ZK 3.4.x

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.2.0
    • Fix Version/s: 0.8.2.0
    • Component/s: core
    • Labels:
      None

      Description

      ZK 3.4.x specifies a dependency on netty. However, that dependency is optional (ZOOKEEPER-1681). To avoid potential jar conflict, it's better to exclude netty dependency from Kafka.

        Attachments

          Activity

            People

            • Assignee:
              junrao Jun Rao
              Reporter:
              junrao Jun Rao
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: