Kafka
  1. Kafka
  2. KAFKA-155

Support graceful Decommissioning of Broker

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.7
    • Fix Version/s: 0.8.0
    • Component/s: None
    • Labels:
      None

      Description

      There should be a graceful way of decommissioning the broker so that there is absolutely 0 data loss. Decommissioning is not necessarily related to replication (Kafka-50).

      There should be a way to get the broker out of the cluster only from the produce side. Consumers should be able to continue keep pulling data. When the administrator is sure that all data has been consumed by consumers, broker node can be removed permanently.

      Same would be useful for rolling upgrades without any message loss.

        Activity

        Neha Narkhede added a comment -

        Oh, right, i meant the partition reassignment tool

        Jun Rao added a comment -

        You mean the partition reassignment tool, not preferred replication election tool, right?

        Neha Narkhede made changes -
        Affects Version/s 0.7 [ 12317243 ]
        Neha Narkhede added a comment -

        ShutdownBroker admin command does not completely achieve this. It merely moves the leader from that broker and then shuts the broker down. But now, some of the partitions could be under replicated. What really solves the problem is preferred replica election admin command. This allows you to add new brokers to an existing cluster, move some partition off of the brokers to be decommissioned and then shutdown the broker by killing it.

        Maxime Brugidou made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 0.8 [ 12317244 ]
        Resolution Fixed [ 1 ]
        Maxime Brugidou added a comment -

        I think this is done in 0.8 branch with the ShutdownBroker admin command (which goes through JMX command KafkController.shutdownBroker())

        Sharad Agarwal created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Sharad Agarwal
          • Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development