Uploaded image for project: 'Kafka'
  1. Kafka
  2. KAFKA-1485

Upgrade to Zookeeper 3.4.6 and create "shim" for ZKCLI so system tests can run

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.1.1
    • Fix Version/s: 0.8.2.0
    • Component/s: None
    • Labels:

      Description

      I can't run projects alongside Kafka that use zookeeper 3.4 jars. 3.4 has been out for 2.5 years and seems to be ready for adoption.

      In particular Apache Storm will upgrade to Zookeeper 3.4.x in their next 0.9.2 release. I can't run both versions in my tests at the same time.

      The only compile problem I saw was in EmbeddedZookeeper.scala

        Attachments

        1. KAFKA-1485.2.patch
          2 kB
          Gwen Shapira
        2. KAFKA-1485.3.patch
          5 kB
          Gwen Shapira
        3. KAFKA-1485.4.patch
          5 kB
          Gwen Shapira
        4. KAFKA-1485.patch
          2 kB
          Gwen Shapira

          Issue Links

            Activity

              People

              • Assignee:
                gwenshap Gwen Shapira
                Reporter:
                machielg Machiel Groeneveld
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: