Kafka
  1. Kafka
  2. KAFKA-1473

transient unit test failure in testRequestHandlingDuringDeleteTopic

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.2.0
    • Fix Version/s: 0.8.2.0
    • Component/s: core
    • Labels:
      None

      Description

      kafka.admin.DeleteTopicTest > testRequestHandlingDuringDeleteTopic FAILED
      org.scalatest.junit.JUnitTestFailedError: fails with exception
      at org.scalatest.junit.AssertionsForJUnit$class.newAssertionFailedException(AssertionsForJUnit.scala:102)
      at org.scalatest.junit.JUnit3Suite.newAssertionFailedException(JUnit3Suite.scala:149)
      at org.scalatest.Assertions$class.fail(Assertions.scala:731)
      at org.scalatest.junit.JUnit3Suite.fail(JUnit3Suite.scala:149)
      at kafka.admin.DeleteTopicTest.testRequestHandlingDuringDeleteTopic(DeleteTopicTest.scala:118)

      Caused by:
      org.scalatest.junit.JUnitTestFailedError: Test should fail because the topic is being deleted
      at org.scalatest.junit.AssertionsForJUnit$class.newAssertionFailedException(AssertionsForJUnit.scala:101)
      at org.scalatest.junit.JUnit3Suite.newAssertionFailedException(JUnit3Suite.scala:149)
      at org.scalatest.Assertions$class.fail(Assertions.scala:711)
      at org.scalatest.junit.JUnit3Suite.fail(JUnit3Suite.scala:149)
      at kafka.admin.DeleteTopicTest.testRequestHandlingDuringDeleteTopic(DeleteTopicTest.scala:120)

      1. KAFKA-1473.patch
        6 kB
        Guozhang Wang

        Activity

        Jun Rao added a comment -

        Thanks for the patch. +1. Committed to trunk.

        Guozhang Wang added a comment -

        Created reviewboard https://reviews.apache.org/r/22220/
        against branch origin/trunk

        Jun Rao added a comment -

        I think we probably need to make sure the metadata cache in the broker no longer has the deleted partitions before testing the failure of the producer requests.


          People

          • Assignee:
            Guozhang Wang
            Reporter:
            Jun Rao
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development