Kafka
  1. Kafka
  2. KAFKA-146

testUnreachableServer sporadically fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Component/s: None
    • Labels:
      None

      Description

      (If anyone can tell me how to convince Jira to do verbatim output, I would be grateful)

      This seems to fail about 50% of the time on builds.apache.org, also reported by Bao Thai Ngo on the -dev list. I have not had success reproducing it locally on my Ubuntu laptop.

      [0m[[0minfo[0m] [34m[0m
      [0m[[0minfo[0m] [34m== core-kafka / kafka.javaapi.producer.SyncProducerTest ==[0m
      [0m[[0minfo[0m] [0mTest Starting: testUnreachableServer[0m
      First message send retries took 365 ms
      [0m[[31merror[0m] [0mTest Failed: testUnreachableServer[0m
      junit.framework.AssertionFailedError: null
      at junit.framework.Assert.fail(Assert.java:47)
      at junit.framework.Assert.assertTrue(Assert.java:20)
      at junit.framework.Assert.assertTrue(Assert.java:27)
      at kafka.javaapi.producer.SyncProducerTest.testUnreachableServer(SyncProducerTest.scala:75)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.junit.internal.runners.TestMethodRunner.executeMethodBody(TestMethodRunner.java:99)
      at org.junit.internal.runners.TestMethodRunner.runUnprotected(TestMethodRunner.java:81)
      at org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
      at org.junit.internal.runners.TestMethodRunner.runMethod(TestMethodRunner.java:75)
      at org.junit.internal.runners.TestMethodRunner.run(TestMethodRunner.java:45)
      at org.junit.internal.runners.TestClassMethodsRunner.invokeTestMethod(TestClassMethodsRunner.java:71)
      at org.junit.internal.runners.TestClassMethodsRunner.run(TestClassMethodsRunner.java:35)
      at org.junit.internal.runners.TestClassRunner$1.runUnprotected(TestClassRunner.java:42)
      at org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
      at org.junit.internal.runners.TestClassRunner.run(TestClassRunner.java:52)
      at org.junit.internal.runners.CompositeRunner.run(CompositeRunner.java:29)
      at org.junit.runner.JUnitCore.run(JUnitCore.java:121)
      at org.junit.runner.JUnitCore.run(JUnitCore.java:100)
      at org.junit.runner.JUnitCore.run(JUnitCore.java:91)
      at org.scalatest.junit.JUnitSuite$class.run(JUnitSuite.scala:261)
      at kafka.javaapi.producer.SyncProducerTest.run(SyncProducerTest.scala:33)
      at org.scalatest.tools.ScalaTestFramework$ScalaTestRunner.run(ScalaTestFramework.scala:40)
      at sbt.TestRunner.run(TestFramework.scala:53)
      at sbt.TestRunner.runTest$1(TestFramework.scala:67)
      at sbt.TestRunner.run(TestFramework.scala:76)
      at sbt.TestFramework$$anonfun$10$$anonfun$apply$11.runTest$2(TestFramework.scala:194)
      at sbt.TestFramework$$anonfun$10$$anonfun$apply$11$$anonfun$apply$12.apply(TestFramework.scala:205)
      at sbt.TestFramework$$anonfun$10$$anonfun$apply$11$$anonfun$apply$12.apply(TestFramework.scala:205)
      at sbt.NamedTestTask.run(TestFramework.scala:92)
      at sbt.ScalaProject$$anonfun$sbt$ScalaProject$$toTask$1.apply(ScalaProject.scala:193)
      at sbt.ScalaProject$$anonfun$sbt$ScalaProject$$toTask$1.apply(ScalaProject.scala:193)
      at sbt.TaskManager$Task.invoke(TaskManager.scala:62)
      at sbt.impl.RunTask.doRun$1(RunTask.scala:77)
      at sbt.impl.RunTask.runTask(RunTask.scala:85)
      at sbt.impl.RunTask.sbt$impl$RunTask$$runIfNotRoot(RunTask.scala:60)
      at sbt.impl.RunTask$$anonfun$runTasksExceptRoot$2.apply(RunTask.scala:48)
      at sbt.impl.RunTask$$anonfun$runTasksExceptRoot$2.apply(RunTask.scala:48)
      at sbt.Distributor$Run$Worker$$anonfun$2.apply(ParallelRunner.scala:131)
      at sbt.Distributor$Run$Worker$$anonfun$2.apply(ParallelRunner.scala:131)
      at sbt.Control$.trapUnit(Control.scala:19)
      at sbt.Distributor$Run$Worker.run(ParallelRunner.scala:131)

      1. KAFKA-146.patch
        7 kB
        Neha Narkhede
      2. KAFKA-146.patch
        3 kB
        Neha Narkhede

        Activity

        Neha Narkhede added a comment -

        This test keeps failing on and off on Mac boxes as well. Basically, it is written to test the producer reconnect timeout, so it is timing dependent. I think we should clean all unit tests that have a timing dependency.

        For this ticket, I've attached a patch that deletes these tests from the unit test suite.

        Jun Rao added a comment -

        It seems that the problem is caused by this assertion: Assert.assertTrue((firstEnd-firstStart) < 300). However, I don't see too much value of these 2 tests and would agree that they can be removed. We should also remove the same tests in javaapi too.
        .

        Neha Narkhede added a comment -

        Deleted those tests from kafka.producer.SyncProducerTest as well as kafka.javaapi.producer.SyncProducerTest

        Jun Rao added a comment -

        +1

        Neha Narkhede added a comment -

        Committed this patch. Thanks!


          People

          • Assignee:
            Neha Narkhede
            Reporter:
            Chris Burroughs
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development